Group Details Private

administrators

Administrators of the Forum

  • RE: Slotmachine breaks after one time usage

    @joshy The script has not been changed since Feb 24th. Did you check to ensure that cooldowns were not enabled? Are there any errors on the Console or in the logs? Were any other changes made to the language files or any other data files.

    This is 2.3.5.3, stock; with and without cooldown. Did you verify that a cooldown was not applied?

    [morpheus] /opt/iobot/PhantomBot-2.3.5.3
    illusion% ./launch.sh 
    [05-26-2017 @ 16:34:10.960 GMT] The working directory is: /usr/local/opt/iobot/PhantomBot-2.3.5.3
    [05-26-2017 @ 16:34:10.965 GMT] Enabling Script Reloading
    [05-26-2017 @ 16:34:10.967 GMT] 
    [05-26-2017 @ 16:34:10.967 GMT] PhantomBot Version: 2.3.5.3
    [05-26-2017 @ 16:34:10.968 GMT] Build Revision: 59603313
    [05-26-2017 @ 16:34:10.968 GMT] Creator: mast3rplan
    [05-26-2017 @ 16:34:10.968 GMT] Developers: PhantomIndex, Kojitsari, ScaniaTV, Zelakto & IllusionaryOne
    [05-26-2017 @ 16:34:10.968 GMT] https://phantombot.tv/
    ...
    slot
    [05-26-2017 @ 10:34:35.066 MDT] [MUTED] The Man IllusionaryBot: [ Kappa KappaPride Kappa ]  +1 point. Baby, now you're number one, shining bright for everyone!
    slot
    [05-26-2017 @ 10:34:35.825 MDT] [MUTED] The Man IllusionaryBot: [ Kappa ResidentSleeper deIlluminati ] My dad could win, and he's dead!
    slot
    [05-26-2017 @ 10:34:36.549 MDT] [MUTED] The Man IllusionaryBot: [ deIlluminati KappaPride KappaPride ]  +4 points. Sometimes in life you don't always feel like a winner, but that doesn't mean you're not a winner.
    slot
    [05-26-2017 @ 10:34:37.113 MDT] [MUTED] The Man IllusionaryBot: [ Kappa ResidentSleeper BloodTrail ] Believe in the heart of the cards!
    ...
    cooldown slot 60
    [05-26-2017 @ 10:35:01.345 MDT] [MUTED] @IllusionaryBot, cooldown for command !slot has been set to 60 seconds.
    
    slot
    [05-26-2017 @ 10:35:04.389 MDT] [MUTED] The Man IllusionaryBot: [ BloodTrail BloodTrail KappaPride ]  +10 points. You got lucky.
    [05-26-2017 @ 10:35:29.484 MDT] illusionaryone: !slot
    [05-26-2017 @ 10:35:38.827 MDT] illusionaryone: !slot
    [05-26-2017 @ 10:35:51.206 MDT] illusionaryone: !slot
    [05-26-2017 @ 10:36:27.373 MDT] illusionaryone: !slot
    [05-26-2017 @ 10:36:27.388 MDT] [MUTED] Pleeb IllusionaryOne: [ KappaPride ResidentSleeper BloodTrail ] Hm! You should go back to playing puzzle games!
    cooldown slot 0
    [05-26-2017 @ 10:36:59.918 MDT] [MUTED] @IllusionaryBot, cooldown for command !slot has been set to 0 seconds.
    [05-26-2017 @ 10:37:13.202 MDT] illusionaryone: !slot
    [05-26-2017 @ 10:37:13.214 MDT] [MUTED] Pleeb IllusionaryOne: [ deIlluminati BloodTrail BloodTrail ]  +10 points. Keep it up!
    [05-26-2017 @ 10:37:18.470 MDT] illusionaryone: !slot
    [05-26-2017 @ 10:37:18.483 MDT] [MUTED] Pleeb IllusionaryOne: [ Kappa BloodTrail Kappa ]  +1 point. Baby, now you're number one, shining bright for everyone!
    [05-26-2017 @ 10:37:25.632 MDT] illusionaryone: !slot
    [05-26-2017 @ 10:37:25.645 MDT] [MUTED] Pleeb IllusionaryOne: [ KappaPride Kappa BloodTrail ] Don't make excuses for your loss! Go train and try again!
    
    posted in Technical Support
  • RE: Slotmachine breaks after one time usage

    @joshy Do you have a cooldown enabled by chance? This is my bot, running the command a few times:

    slot
    [05-26-2017 @ 09:59:21.437 MDT] [MUTED] The Man IllusionaryBot: [ BloodTrail Kappa KappaPride ] Hah ha ha ha ha ha ha!
    slot
    [05-26-2017 @ 09:59:22.672 MDT] [MUTED] The Man IllusionaryBot: [ ResidentSleeper deIlluminati Kappa ] Hm! You should go back to playing puzzle games!
    slot
    [05-26-2017 @ 09:59:23.630 MDT] [MUTED] The Man IllusionaryBot: [ BloodTrail Kappa BloodTrail ]  +10 points. ?!......... (Seriously?!)
    slot
    [05-26-2017 @ 09:59:24.418 MDT] [MUTED] The Man IllusionaryBot: [ Kappa BloodTrail BloodTrail ]  +10 points. Dreams do come true!
    

    Also, what version of PhantomBot? I presume the latest.

    posted in Technical Support
  • RE: Youtube Volume not changing with - or +

    @t-rex91 Looks like it was removed after another merge, will have to merge in the change again.

    posted in Bug Reports
  • RE: Websocket unable to connect

    @WTMike24 I cannot speculate as to the release date for the next stable release at this time unfortunately. More people are actively testing the Nightly which helps a lot, you could always choose an earlier snapshot from the build that HTTPS issues were resolved in and run it in test and see if it is stable enough to stay with. Some folks are using the Nightly right now and seem pretty happy.

    posted in Technical Support
  • RE: Keep Bot On for Discord

    @themeechelle No there is not, when you shut the bot down it terminates the connection to Discord just like if you quit the client completely. If you wish to not have the application open locally then you could look into other hosting solutions which a lot of other streamers do that use PhantomBot. You could also look into a Raspberry Pi or another low-power solution.

    posted in General Discussion
  • RE: Websocket unable to connect

    @WTMike24 I see that you are using HTTPS. Please read this thread:

    https://community.phantombot.tv/topic/2249/bugs-with-the-https/36

    For some folks, the stable has issues with HTTPS. I never had these issues from my VPS, but, other people have and we tweaked the 3rd party WebSockets library after reading that other users of that library (not PhantomBot) were having some issues and the fixes proposed were not working from their development tree.

    Please review your error logs as well and see if they match what the other user was reporting in that thread. If you require HTTPS you will need to update to the Nightly. Otherwise, you should remove HTTPS.

    Also, HTTPS was much slower than HTTP if that is a recent change that was made. The enhancements made in the Nightly seem to help with that.

    posted in Technical Support
  • RE: cyrillic symbols and !songrequest

    @Mewok I am sorry I didn’t have a better answer. We have bumped into this before. The closest we can come is to making a custom module that dumps regular expression checks, but, then, it isn’t as efficient (fast) or accurate as a regular expression.

    My guess on YouTube, is the query has to be encoded (but not sure which encoding YouTube wants on that API). I also assume that Rhino is passing in the unicode properly to the Java Core (but that would need to be checked).

    Sorry for short answers, working right now!

    Cheers

    posted in Technical Support
  • RE: cyrillic symbols and !songrequest

    @Mewok !wordcount uses RegEx which is not compatible with Cyrillic characters under the Rhino/JavaScript engine.

    posted in Technical Support
  • RE: cyrillic symbols and !songrequest

    @Mewok More than likely you would need to look into the Java Core and the YouTube API (see Google YouTube API v3 for this) on how to properly encode such data for their API to work properly.

    posted in Technical Support
  • RE: Working on the Greetings command

    @saleman_89 Greetings have to be set by viewers, we removed the global greetings since it would limit how many messages the bot could send when a few users joined at the same time. As of right now, this only works when the user joins the channel, keep in mind that there is a delay between Twitch sending out the event of a new user joining the channel, usually around 2 minutes.

    posted in Technical Support

Looks like your connection to PhantomBot Community Forums was lost, please wait while we try to reconnect.