Audiohook alias not working anymore


#1

After upgrade to 2.4.2 aliases with “audiohook play audiofile” are not working anymore.
Error: Usage: !audiohook play [audio_hook]

PhantomBot Version: 2.4.2
OS Version: Xubuntu
Java Version:
Browser and Version (for Panel Support):
Stock PhantomBot: Yes/No (Yes if you have not modified the scripts or Java Core)

Let us know what help you need:

If a feature is not working, please provide console output, output from chat, logs, some sort of additional information to help us troubleshoot and provide assistance as needed:


#2

You can’t alias like that, you can alias audiohook play to play for example then people have to use !play audio_hook, but you can’t alias the whole thing. If you want to make audio commands use the !audiohook customcommand command to create them, or use the new panel which makes things way more simple.


#3

Hmm strange i used those audiohook play aliases in previous versions and they worked. Going to try your workaround thanks for the quick answer!


#4

It can work if you do something like the following, there are a bunch of ways to create audio commands, I always recommend using the guide above or the new panel since it allows cooldowns, prices, etc for each command and not just one.

!aliascom !play audiohook play
!aliascom !horn play airhorn


#5

Okay will try this. New Panel is still the way like beta panel right?


#6

Yes.


#7

I set it up with beta panel and it worked great yesterday. Today sound is not playing anymore in beta panel. If i click the sound i can hear it but commands are ignored. My work around is to open another tab with the old panel where the sound is played without problems. Tried different browsers, restarted the bot and installed a new instance as test. Nothing worked so far. Going to test on another computer tomorrow, maybe its a problem on my site.


#8

The beta panel does not handle audio sound anymore. There should have been a warning message about it. Take a look at this.


#9

Alright thanks, maybe i had an old panel tab open somewhere when i testet yesterday. My bad.


closed #10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.