Audiohooks stop Alerts working


#11

I always create a new folder with stuff and only copy databases and configs across. Never drop it over.

When you say it is working is that with the Nightly I used or a newer one? I will try the most recent one and report back


#12

I’m using what’s currently on our GitHub repo, which is the latest nightly. If you still get the same issue, if you could give me the exact steps to reproduce I would appreciate that. I tried what you said above, but I cannot reproduce it.

I’m using http://localhost:25000/alerts?allow-audio-hooks=true&allow-alerts=true&audio-hook-volume=0.8


#13

Just reproduced it now with the latest nightly.

These are the steps:

  1. Open browser to the http://x.x.x.x:25000/alerts page
  2. Fire of a gif alert a few times to make sure its working: eg. !addcom !testbanana (alert banana.gif,5)
  3. Fire off a AudioHook sound. eg. !addcom !yes (playsound yesyes)
  4. Fire off the gif alert again… they no longer work

I have also made an unlisted youtube so you can see everything working as described. https://youtu.be/bGV-C1hp6ZU

Let me know if you need more information.

Thanks


#14

That’s really strange. There is a debug mode for our alerts page, you can turn it on by typing this in your browser’s console.

localStorage.setItem('phantombot_alerts_debug', 'true');

Once you type that, press enter and refresh the page. Try to play your sounds again and take a screenshot, or paste the output here.

Thanks!


#15

Ah! Eureka! I has it.

The extra parameters do the thing!
So… I was running: http://localhost:25000/alerts

Tried all the parameters that you just listed and now it works even in 2.4.1 release. Whew Solved, but definitely still an issue imho because most won’t use those extra parameters.

Thanks Scania


#16

I’m actually confused as to why your audio hooks work, by default they shouldn’t work. I’ll have to look into that.


#17

This guide might help you and others


#18

Perhaps it is because I always have the panel open and it plays the sound through the panel and not the alert box. Because I capture the sound through my main PC and send it to the stream PC that might have caused the sound to transfer.

However it doesn’t explain why sounds killed the alerts page though.

Also, Must have missed that FAQ, would have been helpful. Just saw that alerts where up so added alerts page. Thanks for posting that.


#19

That could be it. I will do some debugging later tomorrow without those parameters and let you know if I find anything.

Sorry for the troubles! Glad it’s working now!


#20

Just happy that it is all working. Was avoiding using sounds because of this and another streamer that I have using the bot was avoiding gif alerts… lol.

Now we can use and spam them and annoy everyone equally. :slight_smile:


#21

Woops… just run into an issue… Sound hooks play through the browser control panel. Just confirmed that… This means that now I am getting double sounds if the panel is open.

Currently searching for a way just to mute that tab or stop the audio from playing through it :frowning:


#22

In the URL change the value for allow-audio-hooks= to false.


#23

As soon as I set it to allow-audio-hooks=false I am back to the original problem. Real solution would be a mute button on the Audio panel so it does not play audio-hooks through the browser.

Currently going to use voicemeeter to put browser on a seperate sound system and mute it while streaming unless I need the browser.


#24

Our new panel doesn’t allow audio hooks to be passed like the current one, so I wouldn’t add this feature. However, I think I know the issue you’re facing right now. Let me look at the code real quick and give you a custom version to try out.


#25

ah ok… I will switch to the beta-panel in the meantime then. Just need to switch back when using give-aways


#26

Try this. It goes in /web/alerts/js

index.js (11.1 KB)


#27

Ok that works… Audio-hooks does not break the alerts. Still plays in the panel though.

I have choices lol.

EDIT: original panel, not the beta one.


#28

It will always play in the current panel. You’d have to remove code to disable it.


#29

Because I am helping a friend with her bot as well… I just installed the beta panel for her. We will probably continue with the beta until it becomes reality. :slight_smile: This way we can have the OBS setup properly and not mess with those links.

Only reason to use non-beta is for giveaways which are not that often.

BTW, good job on the beta so far… looking nice. I might have to give some feedback on that soon. Dashboard layout etc. but different thread of course.


closed #30

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.