Bot seems to start then crashes?


#1

PhantomBot Version:
PhantomBot 2.3.9.1
(https://github.com/PhantomBot/PhantomBot/releases/download/v2.3.9.1/PhantomBot-2.3.9.1.zip)

OS Version:
Ubuntu Server Classic 16.04
(http://www.finnie.org/software/raspberrypi/ubuntu-rpi3/ubuntu-16.04-preinstalled-server-armhf+raspi3.img.xz)

Java Version:
openjdk version "1.8.0_151"
OpenJDK Runtime Environment (build 1.8.0_151-8u151-b12-0ubuntu0.16.04.2-b12)
OpenJDK Client VM (build 25.151-b12, mixed mode)

Browser and Version (for Panel Support):
Stock PhantomBot: Yes
Any Recent Changes to Your System: No (this is a first time install)

Description of Issue:

When I try to start the bot (./launch.sh) I get the following issue generated:

A fatal error has been detected by the Java Runtime Environment:

SIGSEGV (0xb) at pc=0x7587a20e, pid=19584, tid=0x5fe2f470

JRE version: OpenJDK Runtime Environment (8.0_151-b12) (build 1.8.0_151-8u151-b12-0ubuntu0.16.04.2-b12)
Java VM: OpenJDK Client VM (25.151-b12 mixed mode linux-aarch32 )
Problematic frame:
V [libjvm.so+0x30320e]

Core dump written. Default location: /home/botuser/phantombot/core or core.19584

An error report file with more information is saved as:
/home/botuser/phantombot/hs_err_pid19584.log

If you would like to submit a bug report, please visit:
http://bugreport.java.com/bugreport/crash.jsp

./launch.sh: line 33: 19584 Aborted (core dumped) java -Dinteractive -Dfile.encoding=UTF-8 -jar PhantomBot.jar ${1}

HERE IS OUTPUT LOG: https://gist.github.com/OCDiary/eb5535be62dd076915acb23b5fe08696

I cannot seem to get this to work at all, I have tried everything I can think of. Any help would be greatly appreciated!

Thanks
OC


#2

You might have a corrupted version of Java. Try uninstalling java and then reinstalling it, that usually fixes all issue for most users.


#3

Hi ScaniaTV,
Thanks for giving some advice :smiley: I have tried to do that a couple of times, and also completely wiped the sd card and fresh installed a few times too. Unfortunately I encountered the exact same issue each time.
Any more help would be amazing!
Thanks


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.