Deleted botlogin.txt on CentOS 7 problems


So I setup Phantombot on a VPS. Vultr specifically, running CentOS 7. I have had everything running fine for like a month, then realized followers won’t show in chat. Found I needed to add the key for streamelements, I think? Anyway, I opened the directory using Bitvise, opened botlogin, added exactly what it said to on its own line. Then restarted the server. After that, I couldn’t login to the panel anymore. Tried removing what I added, still can’t login. Tried restarting Phantombot on the server and I see in status it says add Twitch name. Long story short, I deleted botlogin.txt thinking it would reset so I could just add what I needed. Nope. Now I am completely lost… Can’t figure out how to get botlogin setup again…what do I do here?


Make a copy of your phantombot.db locally (like on your own computer not the VPS). Terminate phantombot on the VPS, so it’s not running. Delete the phantombot.db from your VPS. Once you restart the bot, it should take you through the setup process.

If for some reason, it doesn’t take you through the process, you should just delete the installation from your VPS and start over.

As long as you have your phantombot.db file, all your data is saved.


Thanks. I’ll give it a whirl. I also found another botlogin file that I call use as a template. Might try that first, then your first suggestion, then full nuclear if I need to.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.