Discord Moderation Log Settings not working


PhantomBot Version:
OS Version: Centos 7
Stock PhantomBot: Yes

Like the title says, Discord Moderation Log Settings not working. Discord Rights are okay, bot does post Announcements of the stream when it goes live and offline, new members and new subs. But the Discord Moderation Log Settings aren’t working. Also tried to move it to general because maybee it was the “_” that fucked it up, but still didnt work.

Twitch clips alert aren’t working, or takes over a hour already. (https://gyazo.com/09d3d893c2868f4ab11e1f13de4a58c7)

Settings: https://gyazo.com/79476d5c6267fc766a3bce7df3fc2570


Is there an # in the channel name for the mod log? If there is, take it out.


In the console? No, like you can see in the gyazo’s.


Sorry, I looked at them, noticed, then immediately forgot. :man_facepalming:

I’m not sure why the underscore would be causing that issue, but clearly it’s not if you moved it to general. Only other obvious thing you’ve probably already mentioned but I immediately forgot is if you’ve restarted the bot since you last changed the settings?

As to the clips, I don’t use that module at all, so unfortunately I can be of no help there.


Twitch clips can take time to be posted depending on how Twitch’s API is doing that day, it is far from stable. As for moderation logs, they seem to be working fine for me, make sure that you’ve restarted the bot after enabling the feature and that you see Connected to moderation data feed in your bot’s console once started.


[2017 @ 11:25:18.332 GMT] Connecting to Twitch WS-IRC Server (SSL) [irc-ws.chat.twitch.tv]
[11-23-2017 @ 11:25:19.421 GMT] Connected to [email protected] (SSL)
[11-23-2017 @ 11:25:19.708 GMT] Channel Joined [#raptordaraptor]
[11-23-2017 @ 11:25:20.158 GMT] Connected to Twitch Host Data Feed
[11-23-2017 @ 11:25:20.672 GMT] raptordaraptor ready!
[11-23-2017 @ 11:25:21.332 GMT] Connected to Twitch Moderation Data Feed
[11-23-2017 @ 11:25:21.587 GMT] [ERROR] [onMessage()@TwitchPubSub.java:378] TwitchPubSubWS Error: ERR_BADAUTH <— is still down, awesome.
[11-23-2017 @ 11:25:41.735 GMT] >> Enabling follower announcements
[11-23-2017 @ 11:25:50.179 GMT] >> Enabling hosts announcements
[11-23-2017 @ 11:26:21.326 GMT] Lost connection to Twitch Moderation Data Feed, retrying in 10 seconds

It connects and then disconnectes. Twitch clips still not working.


Is your bot account your caster account as well by any chance?


No, my bot account is different then the account of the caster.


Shutdown the bot, then open the config folder, and then the botlogin.txt file and change whatever is after user= with your bot’s Twitch login name.


There was a weird code behind the


Thanks, fixed it and hopefully all the other problems aswell!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.