Follower alerts?


#1

PhantomBot Version: 2.4.0.1 (Revision: a532ab64)
Control Panel Version 1.1
Java Version: 1.8.0_161-b12
OS Version: Mac OS X
Let us know what help you need:
Hiya. I’m having a few issues navigating phantom bot and getting a few commands to work.
Let me start with console. what is this and where is it located. many commands need to be typed in the console and not being able to find where it is is a burden. might just be me being silly but Is It in the commands area in (local host) dashboard? My next issue is the follower alert system. The handler is enabled and the point system is enabled and set up. however no alerts are being shown to me through chat. I’m also struggling to do “follower tests” and I assume and have read you need to type the commands in console…

Really appreciate any responses I get.

Many thanks - Doozy


#2

Hey, the console is the black window that pops up when you launch the bot, assuming you followed the MacOS setup guide you should see a screen similar to this.


#3

I closed that and now just copy the (local host) link into my browser. Any idea how to get it back up again?


#4

Assuming you followed the last part of this guide you can simply double click on the launch.sh file from the PhantomBot folder. That console has to stay opened if you want the bot on.


#5

I don’t believe I did the last step when setting up the bot to be able to launch the bot from launch.sh. I just tried launching again from terminal the first steps -
cd Documents/
mv PhantomBot-x.x PhantomBot - Note replace x.x with the current bot version.
cd PhantomBot/
chmod u+x launch-service.sh
chmod u+x launch.sh

However it came up with a bunch of errors…

Is there a way around this. Appreciate the help!


#6

Can you show me the errors? You should also be able to do the last step now, the bot should be in your documents folder.


#7

These are the errors when attempting to do the last step.
Last login: Wed Feb 21 19:24:11 on ttys000
Nicks-Air:~ nick$ /Users/nick/Documents/PhantomBot/launch.sh ; exit;
[02-21-2018 @ 19:24:22.635 GMT] The working directory is: /Users/nick/Documents/PhantomBot
[02-21-2018 @ 19:24:22.638 GMT] Detected Java 1.8.0_161 running on Mac OS X 10.12.6 (x86_64)
[02-21-2018 @ 19:24:22.642 GMT]
[02-21-2018 @ 19:24:22.642 GMT] PhantomBot Version: 2.4.0.1
[02-21-2018 @ 19:24:22.643 GMT] Build Revision: a532ab64
[02-21-2018 @ 19:24:22.643 GMT] Creator: mast3rplan
[02-21-2018 @ 19:24:22.643 GMT] Developers: PhantomIndex, Kojitsari, ScaniaTV, Zelakto & IllusionaryOne
[02-21-2018 @ 19:24:22.644 GMT] https://phantombot.tv/
[02-21-2018 @ 19:24:22.644 GMT]
[02-21-2018 @ 19:24:23.094 GMT] [ERROR] [checkPortAvailabity()@PhantomBot.java:363] Port is already in use: 25000
[02-21-2018 @ 19:24:23.094 GMT] [ERROR] [checkPortAvailabity()@PhantomBot.java:364] Ensure that another copy of PhantomBot is not running.
[02-21-2018 @ 19:24:23.095 GMT] [ERROR] [checkPortAvailabity()@PhantomBot.java:365] If another copy is not running, try to change baseport in ./config/botlogin.txt
[02-21-2018 @ 19:24:23.095 GMT] [ERROR] [checkPortAvailabity()@PhantomBot.java:366] PhantomBot will now exit.
logout
Saving session…
…copying shared history…
…saving history…truncating history files…
…completed.

[Process completed]


#8

That means you already have another bot running. Are you sure you didn’t just minimize the terminal (console) before?


#9

This promising. I think I had the java file open…
[02-21-2018 @ 19:27:03.093 GMT] Channel Joined [#twitchdoozy]
[02-21-2018 @ 19:27:03.350 GMT] doooozybot ready!
followertest
[02-21-2018 @ 19:27:19.417 GMT] [CONSOLE] Executing followertest (User: MOp5XogsbD)
[02-21-2018 @ 19:27:23.398 GMT] >> Enabling follower announcements

could this be the reason why follower notifications weren’t working?


#10

You typed the command just a tad too fast, you need to wait for the Enabling follower announcements line to show up before using the command. It should work now if you try it again.


#11

okay. so the follower announcement worked in console. hopefully this means it works in chat?
appreciate the help!! many thanks.


#12

Yup it should be it in chat too. Np!


#13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.