Host command doesn't work


#1

PhantomBot Version: 2.3.8
OS Version: Windows 7 6.1
Java Version: 1.8.0_144
Browser and Version (for Panel Support): Vivaldi 1.12.955.20
Stock PhantomBot: Yes
Any Recent Changes to Your System: No

Description of Issue: So far everything in phantom bot has been working so well, I love it! The only thing that doesn’t work is host command in the panel. I can use the raid raid channel and income raid channel commands just fine, it’s just the host channel command that never works for me. Any ideas why it wouldn’t be working?


#2

Check your logs/private-messages directory and after running the host command, check the latest log and look for what is replied. You might need to add the bot as a Channel Editor to your channel on your Dashboard, on top of the original verification to get the API key.

Example, this is with my test bot not having Channel Editor access on the Dashboard:

[09-21-2017 @ 22:00:03.024 MDT] jtv: you don't have permission to perform that action.

This is after giving the bot Channel Editor:

[09-21-2017 @ 22:06:55.769 MDT] jtv: now hosting illusionaryone.
[09-21-2017 @ 22:06:55.771 MDT] Received a start host mode notification on user illusionaryone from jtv
[09-21-2017 @ 22:06:55.774 MDT] jtv: 2 host commands remaining this half hour.
[09-21-2017 @ 22:06:55.775 MDT] jtv: 2 host commands remaining this half hour.

PhantomBot Control Panel not updating game or title
#3

I checked the logs and mine were the exact same as yours except for the name obviously. Added phantombot as the Channel Editor fixed it and hosting works just fine through phantom bot. Thanks for the help Illusionary!

Also thank you for the awesome bot, i’m loving it!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.