How can I hide Phantom bot behind cloudflare?


#1

I have phantombot running on a VPS (Debian) and a domain, but everything goes through Cloudflare.

However, the only way I can access the youtube player playlist is by http://IP:25000

using domain.com:25000 doesn’t work.

what I would like to do is have it so someone can either access domain.com:25000 or bot.domain.com and both access phantombot.

I want the IP hidden at all times.

Thanks


#2

This topic has some useful information for you.


#3

You’ll want to look into a reverse proxy for this. I’d recommend either nginx or apache.

https://httpd.apache.org/docs/2.4/howto/reverse_proxy.html


#4

Thank you, that works.

Here’s the code for Lighttpd incase this shows up on Google

$HTTP[“host”] =~ “pb.website.com” {
proxy.server = ( “” => ("" => ( “host” => “127.0.0.1”, “port” => 25000 )))
}

mod_proxy needs to be enabled (lighty-enable-mod proxy)

And thank you for the bot


#5

Ok this doesn’t actually work.

Not everything shows up correctly.

The user/points tables don’t show up, and neither does the marker next to toggle

Doesn’t work for ytplayer or playlist either. Seems like anything involving JavaScript is broken?


#6

Make sure you have your reverse proxy handle port 25004 (panel socket) and 25003 (YouTube player socket)


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.