Introducing The NEW PhantomBot Control Panel


#1

You read that right, today we're unveiling the most anticipated and requested feature that everyone has been asking for. A new control panel. We'd like to start of saying that yes, we know that our users have been asking this for a very long time, however something like this just doesn't happen overnight. We wanted to make the best control panel experience you could ask for, and today we're delivering that to you in our first BETA release.


This is a companion discussion topic for the original entry at https://blog.phantombot.tv/introducing-the-new-phantombot-control-panel/

#2

Please post all issues, bugs, suggestions, and feedback you have about this new panel in this topic.

Thanks!


#3

#4

Quotes showing an invalid date :slight_smile:


#5

Can you show me a screenshot of your quotes table in a database browser?


#6

Can do mate :slight_smile:

EDIT:
its the " " around the date


#7

Okay I think I know why. Why it worked for me is another thing.


#8

Try updating this file.

/beta-panel/js/pages/quotes

quotes.js (7.3 KB)


#9

i fixed it by removing the " around the date in the database


#10

Just updated the download link.

Fixed:

  • Panel not loading and always showing the 60 second wait message.
  • Quotes date not showing properly.

#11

I can’t the beta panel to load. It says “failed to auth to socket.” The old panel works fine.


#12

Did you make sure that the bot was off when you added betap=true to your botlogin file? Also, make sure that you’re using the panel with today’s release or it will not work.


#13

I’m pretty sure I did. I’ll try it again though. Since I already saved the botlogin file, should I just restart the bot?


#14

Yes, also double check to make sure you added betap=true in your botlogin file.


#15

Working now. I think the problem was that I didn’t download from the latest download link. Thanks.


#16

First of all: Thank you! I really love the new panel and I’m looking forward to play around with it.

Just a little thing I noticed: The use of titles on subpages is a little inconsitent. Sometimes the subpages get their own name e.g. “Blacklist” and sometimes the subpages just inherit the name of the main category e.g. “Currency” gets the title “Loyalty”. And this was the exact case where it confused me because “Currency” doesn’t have a panel on its subpage that says something like “Currency Settings” like other pages do. So for a long moment it seemed to me that I was looking at the settings for the “Loyalty” page.

As this mentioned case isn’t the only one I’m not sure which case is the intended behaviour.

Of course this is just a visual thing, but it may be something you want to look into.


#17

You’re right about the titles. I will update the file and update the download link once I get more issues fixed.

Thank you for your feedback!


#18

well i completely shut down the bot and downloaded the link from the blog post at the bottom and added that line to the botlogin.txt but still getting the fail auth at socket thing when trying to load the bot up with the beta panel :confused:


#19

will there be big changes until full release or can i start with the translation? :smiley:

edit: nevermind looks like i have to make a complete new translation anyway, translation triggers “60 seconds” bug ^^


#20

to expand on this shouldn’t Loyalty subpage be called Time