Introducing The NEW PhantomBot Control Panel


#63

Hmm, no luck still. Tried removing it and deleting anything after that line. Restarted the service , stopped it and added again still same issue. Permissions look good on everything botuser is owner and group.


#64

The only thing I can think of is that when you updated the bot core didn’t get replaced correctly. This panel will only work with version 2.4.0.3 of PhantomBot. I know the panel shows that version which is weird, but that’s my only guess at this point.

Maybe you have multiple bots running as well.


#65

Going on a hunch i disabled my https in the botlogin, now the beta-panel works. Not sure why but it doesn’t work with HTTPS.


#66

That’s interesting. I’ll have to look into it. I assume it worked fine with the old panel, right?


#67

Yup old panel is just fine its only the new panel. Something to configure in AdminLTE?


#68

Nope, we found the issue.
It’ll be fixed in the next release of PhantomBot. You can also download tomorrow’s nightly build as well and it should resolve it.


#69

Like Zack mentioned, I was missing code in the HTTPS server handler.

Feel free to try this core.

PhantomBot.jar (440.2 KB)


#70

With @ScaniaTV’s new PhantomBot.jar it works! Thanks Zelakto and ScaniaTV for the speedy fix!

For any other users who want to do this now. Just download ScaniaTV’s PhantomBot.jar file and replace it with the one in your phantombot directory. Or else just wait till the next update!


#71

Props to you for actually figuring out and setting up SSL, we don’t see that often from users. Thanks for helping us test.


#72

I’m a IT professional by trade so , I’m a small margin of your user base , something like the https testing could be easily overseen since i’m sure 95% of your user base doesn’t use it or know how to set it up. Happy to help and contribute, that’s how open source thrives. Thank you guys for making an awesome bot!


#73

Little off topic here, but next thing you need is a proxy for that port on the end. :wink:


#74

Challenge accepted.

I did it through IPTable Rules

For the curious my server is Ubuntu 16.4 hosted on AWS
Instructions:

Type sudo su in terminal to get to root user

type this to backup your iptables iptables-save > /opt/iptables.backup

type this command for https iptables -A PREROUTING -t nat -p tcp --dport 443 -j REDIRECT --to-ports 25000

type this command for http iptables -A PREROUTING -t nat -p tcp --dport 80 -j REDIRECT --to-ports 25000

type this to keep change persistent iptables-save > /etc/iptables.rules

Should work right after, might need to restart server/phantombot

If there’s any issues restore iptables with iptables-restore < /opt/iptables.backup and that will revert your firewall back.

image


#75

Would love to be able to type in a command in the ‘Run Command’ area - specifically echo. Under the old panel I could just type it out, but this new one seems to be a dropdown with search instead of command line.


#76

When clicking the Aliases page i get this

Uncaught TypeError: $.fn.dinamicMenu is not a function
    at Object.success (ajaxLoader.js:28)
    at i (jquery.min.js:2)
    at Object.fireWith [as resolveWith] (jquery.min.js:2)
    at A (jquery.min.js:4)
    at XMLHttpRequest.<anonymous> (jquery.min.js:4)

#77

Does this happen with the socket panel? It seems to work fine for me.


#78

yes does it on every page i click on


#79

That means a function wasn’t registered, so try downloading the panel again. Don’t replace any files delete the old ones.


#80
Uncaught TypeError: $.fn.dinamicMenu is not a function
    at Object.success (ajaxLoader.js:3)
    at i (jquery.min.js:2)
    at Object.fireWith [as resolveWith] (jquery.min.js:2)
    at A (jquery.min.js:4)
    at XMLHttpRequest.<anonymous> (jquery.min.js:4)

Now im getting it on a different line line wierd

edit
after deleting adminlte.min.js and readding it then it fixed it :slight_smile:


#81

Aweseom work, can’yt wait to test the rest of the panel that is locked right now.


#82

I don’t know if it’s on purpose but am i supposed to not be able to click on settings while the stream is offline?

Btw. the new panel looks awesome!! <3

EDIT:
To be more precise: i can’t click on any menu point after keywords.