Introducing The NEW PhantomBot Control Panel


#104

I see. But please keep in mind if this may become possible in the future.


#105

Hi! I can’t seem to download the new file from the blog post. The link takes me to the ZelCloud site and makes me sign in. I am on a Windows computer


#106

Hey, I literally was just able to download it to set up the panel for a friend. So it should be working correctly. Try this link and let me know what happens.

Thanks!


#107

It worked!!! Thank you!!!


#108

I have another Question!
How do you transfer the ranks from the last version to this one? I set up some global ranks and they didn’t transfer…


#109

The new panel has a bug:
If you add some word to the blacklist in the new panel, the filter does not work. But if you go back to the old panel and click “Edit” and “Save” on the same entry created in the new panel, then the filter starts to work.


#110

Will be fixed in the next update


#111

Now if this is almost an reality when we will have an pannel for the followers


#112

That requires a different panel source base that handles multiple users and would pretty much require a server to run (who wants to give their home IP address out?). I have started to plan out how to do this with Spring MVC, and have been able to prototype the idea (more or less) with the Data Rendering Service. Since the idea would be to allow multiple permissions, even the new panel (as far as I know) isn’t entirely geared toward that.

I also will not commit a date to this.

Perhaps though, by a followers panel, you mean the ability to see their points, time, ranks, and custom commands. Have you looked at the PhantomBot DRS?


#113

12

Just open IP:25001/beta-panel


#114

panel finished ?


#115

No it’s still a work in progress.


#116

Hi,

The beta panel works for me on my CentOS VPS. However, after a short period, I always get ‘Connection lost with the websocket.’

Is there something I need to correct at my end?

Thanks,

Neil


#117

Could you let us know if you’re using a reverse proxy of some sort? Or routing everything through cloudflare, etc?


#118

There’s nothing fancy like that. Just via a straight wifi connection to the router which is running a standard connection to my ISP.

N.


#119

It could be network latency. It could be open ports. If you were to look into the logs/core-error directory, see if there is anything mentioned around the websockets.

You may try to use an experimental websocket server (I use this myself) by adding the following to config/botlogin.txt:

testpanelserver=true

This uses a different 3rd party library. No promises, it could still be something related to latency to your VPS or any number of other items.


#120

I’ll implement reconnecting websocket like the current panel for the next beta release.


#121

Many thanks for your help.

N.


#122

Hi,

I’ve been trying to get the beta working since yesterday, thinking I missed something but I did all the steps over and over again and can’t seem to be able to make it work :frowning:
It keeps saying “Please allow the bot to generate the data needed to load this page. Try again in 60 seconds…” but nothing ever happens.

23

I saw that it’s something you already fixed so I don’t get why it’s happening on my end :frowning:

I have nothing on the Terminal but here’s what I get from Chrome’s console:

[PhantomBot Error] Failed to run callback: TypeError: Cannot read property 'views' of null
    at <anonymous>:9:1032
    at Object.func (http://localhost:25000/beta-panel/js/index.js:1:642)
    at WebSocket.webSocket.onmessage (http://localhost:25000/beta-panel/js/index.js:5:35)
[PhantomBot Error] Failed to run callback: TypeError: Cannot read property 'views' of null
    at <anonymous>:9:1032
    at Object.func (http://localhost:25000/beta-panel/js/index.js:1:642)
    at WebSocket.webSocket.onmessage (http://localhost:25000/beta-panel/js/index.js:5:35)

Also tried on Firefox, just in case, but had no luck.
Did I do something wrong?

Thank you
Soo


#123

Please be sure that you’re running the latest version of PhantomBot.