Is it normal for phantombot to turn off host settings?


#1

I don’t know if this is normal or I’m just doing something wrong. Every time I check host settings it seems like Phantombot disables it and I have to keep typing in “!module enable” to turn them back on. Is there a reason why it does this?


#2

Sounds like a bug, or someone is disabling it without your knowledge.

Are there any errors in your console/logs?

Please fill out the following so we can better assist you:

PhantomBot Version:
OS Version:
Java Version:
Browser and Version (for Panel Support):
Stock PhantomBot: Yes/No (Yes if you have not modified the scripts or Java Core)


#3

I don’t see any errors in the windows command. Though it seems that it always disables anything to do with host when I turn off the bot and turn it back on.

Phantombot Version: 2.3.8
OS Version: Windows 10
Java Version: 8 update 144 (build 1.8.0_144-b01)
Browser:Google Chrome
Panel Version: 25000
Stock PhantomBot: Yes


#4

Hey, I think this is something to do with your oauth token. Try the following steps to try to fix this issue.

  1. Make sure that you’re logged into your main Twitch account.
  2. Go to https://phantombot.tv/oauth and generate a new oauth token
  3. Copy the entire oauth string including the oauth: part.
  4. Make sure the bot is off and open the botlogin.txt file located in the main bot folder.
  5. Replace the current oauth that is after the apioauth= variable with your new one.
  6. Save the file and restart the bot and enable the hosts module, then restart the bot again to make sure it stays enabled.

Hope this helps!


#5

Thank you, that did work. ^^


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.