Multilink not working


#1

PhantomBot Version: 2.4.0.3
OS Version: Debian 9
Java Version: 1.8.0_171
Browser and Version (for Panel Support): Chrome 66
Stock PhantomBot: No (modified a couple of files to let the announcements on Discord show the embeds properly)

Hi. I did a fresh install of PhantomBot a couple of days ago and everything went fine, apart from the fact I had to modify a couple of files to let the Discord announcements work properly. Apart from that, the bot is the stock version. Anyway, yesterday I tried to use the multilink function since I was playing together with another streamer, but the multilink never worked since the bot didn’t post the link a single time during the 2 and a half hours period we played together. Is there some bug still waiting to be fixed in a new version (like what’s happening with the Discord announcements) or what?


#2

Hello,
so I am unable to get my !multi to NOT work. Can you make sure you have done the following…



Double check to make sure the module is turned on. Make sure you type in only the person(s) you are streaming with, the bot will automatically add your name. Set your timer/messages & make sure you ‘submit’. Lastly, ‘multi-link timer on’ is how you activate it. You can check with !multi. I showed you two pictures here, one is the command page, the other is the panel page. Let me know if this isn’t working yet for you.
Enjoy!


#3

I used that multiple times, so I know how it works and I usually set it up from the panel. When I activate it I even see the icon on top as it shows in your 2nd screenshot, but the bot doesn’t send the link in chat. Everything else works and the bot responds to other commands, so it’s not as issue with the bot being unable to send messages but I can’t understand what else it could be.


#4

Can you upload a screenshot of your multi link settings?


#5

Sorry for the delay. Here are the settings, used those ones for a long while without problems but it seems they’re not working anymore. Multilink been active for hours and the bot didn’t show the message a single time (even tried changing required messages to 1, but nothing changed).


#6

Can you provide your error, core-error, and stacktrace logs.

I swear someone mentioned this a little while back already. Seems like deja-vu.

Also, what did you have to change for announcements to work? I have announcements working from stream, follows, subscriptions, bits, … and didn’t have to modify anything.


#7

Err… Where do I get those logs from?

For the announcements, I had issues with them on 2.4.0.3 as I mentioned here Discord online/offline alerts not showing embeds anymore


#8

Another question too, are you online when you are testing this?

The logs/ folder in PhantomBot has logs for the types mentioned above.

These embeds?


#9

I’ve put all the logs you requested here:

https://pastebin.com/pdvS4Zev

And for the embeds, yeah they didn’t work on 2.4.0.3 (till I manually made the changes reported in that commit) but now I’m using 2.4.1 so I’m using the stock files.


#10

Well, your bot is having a hard time talking to Twitch. This would be network related or due to using a version of Java that doesn’t authenticate properly:

You are not getting updates from Twitch so the bot doesn’t know the status (online/offline) and that could be your problem. Could also be an API key issue I suppose.

You said you are using Debian - per chance, Raspberry Pi?


#11

No, VPS. Anyway those errors seem related to the issues Twitch has experienced in the last hours. And I didn’t use the multilink today (pointless since it’s not working).


#12

It is working in my channel and in another streamers. I was watching it last night in a person that uses PhantomBot. Are you trying the command when your stream is online (and Twitch can report that it is online)?

Oddly, I don’t have Twitch API errors from my VPS. Must have been on certain networks.


#13

Forced my development bot to think it is online:

[05-30-2018 @ 18:49:30.287 MDT] Data Render Service API Key Present, Enabling Data Feed
[05-30-2018 @ 18:49:30.744 MDT] Connected to Twitch Moderation Data Feed
[05-30-2018 @ 18:49:31.490 MDT] [♫] YouTube Player is connected! [♫]
[05-30-2018 @ 18:49:32.412 MDT] [MUTED] [♫] Now Playing [XXXTENTACION - SAD!] Requester: DJ IObot
[05-30-2018 @ 18:49:32.414 MDT] [MUTED] [♫] Song requests are enabled! [♫]
[05-30-2018 @ 18:49:34.567 MDT] [♫] YouTube Player is disconnected! [♫]
[05-30-2018 @ 18:49:40.227 MDT] [MUTED] http://multistre.am/notillusionaryone/bob/frank
[05-30-2018 @ 18:49:50.456 MDT] >> Enabling follower announcements
[05-30-2018 @ 18:49:50.660 MDT] >> Enabling StreamLabs donation announcements
...
[05-30-2018 @ 18:54:50.227 MDT] [MUTED] http://multistre.am/notillusionaryone/bob/frank
...
[05-30-2018 @ 18:59:50.228 MDT] [MUTED] http://multistre.am/notillusionaryone/bob/frank

I could provide you with a spamming [debug] copy of a test version of the script and disable the online check if you want I suppose. You could see what that does.


#14

Last time I used it was yesterday (intended as May 29th). I usually set it from the web panel, the icon showing it’s working appears, but the bot doesn’t post anything in chat.


#15

No, the icon just indicates that the flip is switched, it does not report that there was a successful condition to allow the timer to send messages.

dualstreamCommand.js (6.6 KB)

This is a test version which does not check for online status and will dump out two lines every 10 seconds to the console if the timer is activated. It will dump one line every 10 seconds otherwise. It will place another debug line before the point where it should send a notice. If it never sends a notice, then that means that there is corruption more than likely in the data.

Shutdown the bot. Make a backup copy of scripts/commands/dualstreamCommand.js in another directory, replace with this one, restart the bot, watch the console.

I’d like to see the Console output.

Thanks


#16

Tried using that script and I include the log from the console in the link below. I must say the !multi command has a different behaviour than the stock script: as you can see in the log, if I use the !multi command the bot replies with the link to the multistream, but with the stock version it replies with the command usage help even if everything’s set up. (P.S. It was a short test, didn’t ran it up to 5 mins as I didn’t had the time, I can run it for longer if needed).

https://pastebin.com/LaEa2ADd


#17

The timer is working, let it go the full five minutes and see if it outputs since that modified version is not checking for the online status of your channel. If the other version doesn’t work, I am thinking your channel is not online or is not being detected as online (Twitch API) and !multi is not firing because of that. You can keep using the modified version, just remove the $.consoleLn() items in the setInterval() code toward the bottom I suppose.

Odd you should say that because that copy is directly from git with the modifications to print out extra items; were you perhaps holding onto a different version? This hasn’t changed since January:

[morpheus] /opt/iobot/src/master/PhantomBot/javascript-source/commands
illusion% git log dualstreamCommand.js
commit a68fbeb1c28a3abd47c2d5757bb5be9042c9da6d
Author: IllusionaryOne <[email protected]>
Date:   Thu Jan 18 10:43:18 2018 -0700

    Beautify JavaScript and Java

commit 1f97b79d1945a6cda046e9138217ebddf06e797e
Author: Wayne <[email protected]>
Date:   Wed Nov 8 22:58:58 2017 +0000

    Updated

    removed the $.username.resolve() from the !multi to match the !multi set

Looking at the stock version from git:

That is exactly what it does, if you have set channels for !multi to report on. So I am confused as to why a version would have behaved differently.

Again, as you can see here:

Hasn’t changed since January 2018.