Notices not running


#21

EDIT: FULLSTOP. I was rushed when I checked yesterday before we headed out the door for a five hour trip to see Nick Cave and the Bad Seeds in Washington, DC last night. And I write that and submit and then say, “Hey, I should make sure I’m not an idiot and that all the things were properly turned on!” and sure enough, I was an idiot and didn’t re-check the two toggles on the notice panel. Sure enough, my bot just spit out the first message in the chat window right after I turned him on! THANK YOU SO MUCH!!

Got the DB and installed… added notices, and nada… it probably has to do with something when I set the whole thing up. I’m just going to start from square one (this was on a Pi that sat in a box for 7 years and was just waiting for the right use). I’ll document my process from the various how-tos I had gotten my information from. Then, hopefully by the end when my bot is running as it should, we can have a Raspberry Pi specific how-to that I can post for others in the future. Thanks for all the help and the patience with my slight manic and keep up the great work. You got a good thing going here! :smile:


#22

So… Things went fine. And then I had to turn the bot off. Upon starting it back up again, the notices issue had returned. Seems I have to replace the DB every time I have to stop and restart the bot. This isn’t a game-breaking deal, as I ultimately plan to have this Raspberry Pi just hooked up and running 24/7, so I just have to replace the DB and add back in my notices when I start it up.

I don’t know why this is happening, but I just wanted you to know for your own developmental processes.

Phantombot is still TOTALLY the shit and its developers are great! Have a good one!


#23

So I’m starting over and I have one question at the beginning here -

When I initially set everything up, this was a sticking point - “sudo chown -R botuser:botuser .” (noted above)

The question is this:

In the Linux/Ubuntu setup referenced above, that command is "sudo chown -R botuser:botuser * "

It has an asterisk * instead of a period .

What’s the difference, or is there any?

Thanks. Hope to get this thing redone and working fully and never have to revisit this phase ever again. :smile:


#24

http://www.linfo.org/wildcard.html


#25

I appreciate the lesson there. I like being led to knowledge potential. :wink:

So if I’m reading things from those two spots correctly, the command “sudo chown -R botuser:botuser .” is specific, whereas the command "sudo chown -R botuser:botuser * " could mean the same thing… or could mean something else (but I’m guessing it doesn’t matter much in this context).

I take it the command with the period might be the better command to use in this case. :smile:


#26

I will put this as a question :slight_smile:

If . is the current directory and * are all contents of the directory, which would modify the current directory and which would skip it?

The period is the better option depending what directory you are in. That would change the owner on the current directory as well as all files and sub-directories (remember, the -R option) while * would ignore the current directory.


#27

I pretty much see what you are saying. The . would modify the current directory, and the * would skip it(?). I think.

I’m still quite new to figuring out Linux/Raspbian and my Pi here. As frustrating as it has been at times, I’ve truly enjoyed the crash course I’ve been going through.

So let’s nail this one down. In the Ubuntu 16.04 LTS setup guide, I get to this point:

The last thing we need to do is to assign the right privileges to make the launch.sh and launch-service.sh files executable.

cd phantombot

chmod u+x launch-service.sh launch.sh
sudo chown -R botuser:botuser *

We have an asterisk there… we are in the Phantombot directory when running that command.

I get to the period thing when I’m troubleshooting my notices which were not working… and on this page - Notices/Timers not working! ScaniaTV initially replies:

These commands have been removed a long time ago, this is either a result of bad permissions for the bot’s database, or a corruption. Please be sure to never upload files as root to your server. While the bot is off, you might want to use the following command as your bot user.

sudo chown -R botuser:botuser . - be sure to be in the bot’s directory before doing this.


So here, I would be in the bot’s directory, which I’m assuming would be the same phantombot directory.

Since, I’m new to all of this, can you see why I want to make sure of things? :wink: I pay attention to details!!

(Hell, I had ScaniaTV edit the upgrade page because I stumbled across an error and made a note of it!)

Anyways, thanks for humoring me here. I appreciate the help.


#28

I give up.

Started from ground zero.

Totally redid the Pi.

Totally installed the bot (adding the botlogin.txt phantombot.db and custom scripts from the instance that I had running on my Mac that was RUNNING PERFECTLY).

Did everything, dotting i’s and crossing t’s.

The bot works wonderfully.

NO NOTICES/TIMERS.

I fucking tap out. This shit is driving me mad. I guess I’ll just NOT have notices/timers.

I don’t know what else to do. :cry:


#29

For any questions:

I ran the "sudo chown -R botuser:botuser * " command as listed in the Ubuntu setup guide. This led to an error that told me that the botuser wasn’t in the sudoers file (just as it had done the first time around). I researched that online and added the botuser to the sudoers file and the command seemingly went through fine.

After no notices, I then ran the “sudo chown -R botuser:botuser .” command as ScaniaTV had suggested in that one post I referenced where someone else was having a similar issue.

I’m at my wit’s end. I don’t know Linux like the back of my hand, so all I can do is follow directions and ask questions and I guess I have no clue what I’m doing or what I’ve done wrong (or what is wrong in the instructions).

I’m tired of this. I need my point system to be up to date, so replacing the phantombot.db with the scrubbed one that ScaniaTV did for me every time I need to reset the Pi is just not an option anymore. I can’t always reset the points to where they were on October 25 just so I can have notices.

I GIVE UP.

Thanks for trying to help me. I don’t know what else to do.


#30

Maybe I’m crazy for thinking this, but can I leave out all the botuser stuff and just have everything work on the root user level? It’s a Pi that I’m only using for this bot. I’ve stuck a firewall on it.

I don’t have any of that stuff when I run the thing on my iMac and it works just fine with no issues (other than I need its CPU power to go to a bunch of other things). I get security and I understand why it’s important and all… but at the end of the day, this is a single board computer running my bot and nothing else.

I just don’t know exactly what is keeping this ONE (pretty important and desirable) function from working.

Ugh.


#31

I did just that. Again, I set up a working bot. But no notices/timers.

So I took the scrubbed phantom.db file dated Oct 25 that ScaniaTV made for me and plugged it in and added the timers and while it ran, I had success.

Upon shutting down and starting it back up, however, no dice. Timers not working.

I have various logs and states of my phantombot.db file. I’m a novice in Linux, but I’m well versed in experimentation. Tried to see what I could make happen. Beta testing? I’m disabled and had to learn how to walk again (not well, heh). I had nothing to lose. I got too much time on my hands.

I guess I’ll just run things off the iMac right now for streaming because it just works.

Let me know if any of this data is desired. I wish we could make this work. I do truly appreciate the help.


#32

THE NIGHTMARE IS OVER.

Last night, I loaded an SD card with Raspbian Jessie to try that as a variable (that’s what IO is running in his spec list up there, I said). Over an hour to run the upgrade cycle. Left the db file out of the mix, started her up and added notices and they played fine. Bot success. Turned it off and on. No notices.

So today I removed the last variable. Loaded Rasbian Stretch on an SD. Maybe twenty minutes of upgrade cycle. In that time I generated new Twitch oauths for the bot and my user account. Started with no pre-built stuff that had been running soundly on my iMac. Started 'er up and added notices. They ran fine. Exited out.

Waited about five minutes, turned 'er on again, and about 15 seconds after going through the bootup cycle,

the first notice dropped.

I’m running it in root, no botuser, whatever.

IT WORKS.

Now to go through and tweak all the knobs and text boxes. Thankfully the beta panel is so much smoother and easier than the regular panel. Didn’t remember how tedious it was until I was just going straight stock out of the box and trying to find the switch to turn notices on.

Never say I’m a quitter. Like I said, it ain’t graceful, but I taught myself how to walk (with canes) again.

Thanks again for the help. Hopefully I’ll just help squash a bug or two from here on out!


#33

I am perplexed that a particular flavor of Raspbian makes it work but great to hear that it does! I have seen a few oddities at times from other distributions on Pi, but nothing like this.


#34

I’m not sure it was a particular flavor of Raspbian that actually did it… it was just one of the variables I changed in my troubleshooting. It seemed that I just needed to start with a fresh botlogin.txt.

And that said, the bot stopped spitting out notices. I’m not sure when it stopped, but it did. I’ve been wrapped up in plenty of other stuff getting my regular stream thing going, so I didn’t really notice.

The bot has been running 24/7 since I “fixed” it. I just rebooted the Pi. No notices firing. I removed all the notices and added them all in again. Fiddled with switches. No notices.

I don’t know what else to do other than just give up. I can’t keep replacing login texts and database files and resetting everything all the time. I just need this thing to work.

Perhaps this bot doesn’t really run well on a first model Pi. I don’t know. I just don’t know what else to do.

And a side note - whereas I had Discord functionality when I’d originally run the bot on my iMac, I get nothing but a bot that logs into Discord with it on the Pi. It doesn’t respond to any queries inside my Discord. It’s there hanging out, but it just ignores everyone. Don’t know if this is a separate issue, but I figured I’d note it.

So I have a bot that plays games and keeps score on Twitch. It doesn’t spit out notices/timers and it logs in, but ignores everyone on Discord.

That’s about all I got right now. Wish I knew how to program so maybe I could figure things out on my own, but I don’t, so I got nothing.

:frowning:


#35

Just looked back through my chat logs, and it looks like the notices ran fine on the first day and then just stopped. I don’t know what happened or what I did wrong, but I’m really ready to just flush this thing down the toilet and find something that JUST WORKS.


#36

And don’t get me wrong… I LOVE Phantombot. This issue aside, this thing has been a breeze to work with. The new beta panel is sweet and I love the functionality.

But it just looks at my notices and tells me to go fuck myself. When people do that to me, I evacuate them from my life. So I’m really torn here. I’m just tired of fighting it.


#37

When I get the extra time, I’m going to try setting up a new bot from scratch. I don’t know if any issues came from transferring things from my iMac to the Pi or what. I don’t see why it would being as this thing runs on Java and otherwise should be independent of any of the operating systems that varying computers run.

But other than this, I don’t know what else to do. I’ve dealt with so much frustration over this shit that it’s brought my usual depressed self to tears. I’M NOT A FUCKING IDIOT. I may not know how to code, but ffs, I’ve gotten this mostly running on a Pi and even got an old Netbook connecting to it via a VNC connection. This isn’t the kind of stuff regular idiots just do.

But my notices? Yeah. The bot tells me “FUCK YOU”.

I really want to tap out.


#38

I can completely understand the frustration, my full time job is a software engineer and manager of a few folks (yeah, I wear a couple of hats - I am happy I still get to code stuff at work though). I run into situations that are pretty confusing and aggravating quite a bit.

As the process runs for about a day and stops, I am beginning to wonder if there is a resource limit or something being hit on the Pi. The notices run in timers (threads) and, when they started working the first time when you went to a large Pi, it just makes me wonder. I may try to leave my bot up for a day or two on a test Pi that I have. At least I could reproduce it, but not sure how to fix that.

As you say, it works fine on other hardware. Unfortunately, PhantomBot is at the mercy of the Java implementation under any OS and hardware. As an example, we once had an issue on the Pi with automatic SQLite backups because a calculation was overrunning the hardware. Some of these things we can find a work around for and other things we might not be able to.


closed #39

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.