PhantomBot Version: 2.3.8-NB-20170818 (Revision: 8fa7d5b)

commands
release
phantombot
discord

#21

there is another test

oh it works just the color is after not before

i fixed it with using


#22

It looks like the API swapped the parameters, will look to move it back to the way it was so people don’t have to redefine their embeds.

util/DiscordUtil.java:    public void sendMessageEmbed(IChannel channel, String message, String color) {
[Nyx] /opt/iobot/src/master/PhantomBot/javascript-source
% grep -R sendMessageEmbed *
discord/core/misc.js:			$.discordAPI.sendMessageEmbed(channel, message.match(embedReg)[1], message.match(embedReg)[2]);
discord/core/moderation.js:        $.discordAPI.sendMessageEmbed(modLogChannel, 'yellow', toSend);
discord/core/moderation.js:        $.discordAPI.sendMessageEmbed(modLogChannel, 'red', toSend);
discord/core/moderation.js:        $.discordAPI.sendMessageEmbed(modLogChannel, 'green', '**Timeout removed from:** ' + '[' + username + '](https://twitch.tv/' + username.toLowerCase() + ')' + ' \r\n\r\n **Creator:** ' + creator);
discord/core/moderation.js:        $.discordAPI.sendMessageEmbed(modLogChannel, 'green', '**Ban removed from:** ' + '[' + username + '](https://twitch.tv/' + username.toLowerCase() + ')' + ' \r\n\r\n **Creator:** ' + creator);

#23

ya i have sent a pull request with the fix for you also if that works for you?


#24

I am actually going to fix the core instead so that the embed works the way that they did before and the API behaves the same. The new API should match the old one. I will see if I can reject individual files from that merge request since you mixed it with quotes (try not to do that :slight_smile: )


#25

ya i tried to send it as its own but when i did it as its own pull request then it added to the current one i had pending


#26

Hmm, typically I do something like this and it seems to open a new pull request:

git checkout -b NewBranch
git commit -a
git push IllusionaryOne
git pull-request

If you push onto the existing branch, it gets added to the pull request that already existed.


#27

oh i was doing it from github itself not the client or what not


#28

I’ll push a fix for this later tonight, the pull requests changes how the variable works which will break for everyone that uses it currently and will break some functions in the bot. For future bugs with the new rewrite please report them here: Discord Module Revamp


#29

Ahh yeah, that may explain it. I am an old man that uses the command line for everything :slight_smile:


#30

I think I already have the fix done, I am about to test it :slight_smile:


#31

ill cancel that pull request and send a new one for the quote if you like???


#32

i would of reported it there but like i said above i cant make a thread or reply in that thread


#33

I’ll fix that, sorry.


#34

Fix in PR 1623

And removed debug statement in 1624 :slight_smile:


#35

This error is you do !account with nothing after it

[08-18-2017 @ 17:18:37.906 BST] [ERROR] [init.js:298] (hook.call, command, ./discord/core/accountLink.js) TypeError: Cannot call method “equalsIgnoreCase” of undefined


#36

First, need to get you on the payroll as a QA Tester. Of course, we don’t pay or make anything, so, by payroll, I mean, kudos and virtual hi-fives :slight_smile:

I just ran in my latest build (master) from Discord:

[08-18-2017 @ 10:46:18.911 MDT] [DISCORD] [#bottest] illusionaryone: !account
[08-18-2017 @ 10:46:18.924 MDT] [DISCORD] [#bottest] [CHAT] <@!114786543234711561>, In order to use this module, make sure the bot is not blocked from private messaging you on Discord.
To link your Discord and Twitch accounts please use the following command **!account link**

It seems to work, but I may not be reproducing correctly, or maybe Scania already fixed this, I didn’t check recent commits.


#37

[08-18-2017 @ 17:49:09.942 BST] justalixe: !account
[08-18-2017 @ 17:49:09.958 BST] [ERROR] [init.js:298] (hook.call, command, ./discord/core/accountLink.js) TypeError: Cannot call method “equalsIgnoreCase” of undefined

This is IF ran from twitch chat not discord chat…

i mistakenly did the command and got this error lol

Also…what does these commands ment to do as they do nothing


#38

Ok, now it makes sense.

The other commands are the bot level commands. They may not appear to do anything, but they do.

illusionarybot moderate
[08-18-2017 @ 11:23:39.429 MDT] send .mods  <-- added debug statement

Private message log, which I was tailing at the time:

[08-18-2017 @ 11:23:39.562 MDT] jtv: the moderators of this room are: illusionarybot, scaniatv

Disconnect:

illusionarybot disconnect
[08-18-2017 @ 11:25:54.852 MDT] [MUTED] @IllusionaryBot, Disconnecting from irc-ws.chat.twitch.tv
[08-18-2017 @ 11:25:55.864 MDT] illusionarybot is shutting down...
[08-18-2017 @ 11:25:55.864 MDT] Stopping all events and message dispatching...
[08-18-2017 @ 11:25:55.864 MDT] Terminating the Twitch channel follower cache...
[08-18-2017 @ 11:25:55.865 MDT] Terminating the Streamlabs cache...
[08-18-2017 @ 11:25:55.865 MDT] Terminating the StreamTip cache...
[08-18-2017 @ 11:25:55.866 MDT] Terminating pending timers...
[08-18-2017 @ 11:25:55.866 MDT] Terminating all script modules...
[08-18-2017 @ 11:25:55.876 MDT] Saving all data...
[08-18-2017 @ 11:25:55.876 MDT] Shutting down all web socket servers...

Reconnect does things behind the scenes. If you check the commands though, some of these are only allowed by the bot account itself (Control Panel or Console).


#39

i just tried them all via the console and what not and get nothing


#40

Try all lowercase.