PhantomBot Version: 2.3.8-NB-20170818 (Revision: 8fa7d5b)

commands
release
discord
phantombot

#41

same thing


#42

Not sure, it works from my bot. You could try to enable debug mode I suppose.


#43

could testpanelserver=true be interfearing with it at all :stuck_out_tongue:


#44

No, I use testpanelserver=true.

IllusionaryBot
[08-18-2017 @ 11:36:38.622 MDT] [MUTED] @IllusionaryBot, !illusionarybot [reconnect / disconnect]
illusionarybot
[08-18-2017 @ 11:36:41.044 MDT] [MUTED] @IllusionaryBot, !illusionarybot [reconnect / disconnect]

Also, sending fix for !account from Twitch. It is a Discord command, should not have been mapped to Twitch.


#45

Per chance, is that an old $.botname that you are referencing? Is that the actual name of the bot?


#46

its the bot i use now i just made it spit out $.botname and this is what it got so thats working

also wasnt !account needed for when you whisper the bot with the ID number it gives u in discord


#47

$.botName.toLowerCase(); instead of $.botName in initCommands.js seems to have fixed it and made the command itself in permissions as lower case


#48

It already worked fine for me in Mixed Case though, as you can see above, and this line does a case insensitive compare:

if (command.equalsIgnoreCase(bot)) {

That does the same as performing the lower case, I suspect something else got tripped when you stopped and restarted.


#49

If it was, not sure how it would have worked from the Twitch side, it calls all Discord related methods that do not exist on the Twitch side.


#50

wierd cus i just changed it back and doesnt work now

also there is no sub command for reconnect in the js file there is only a normal command for reconnect


#51

just to confirm that its broken this command now

adding the code below seems to fix it though :slight_smile:
if (!action) { return; }

but i am also getting the error below if the code is right

[08-18-2017 @ 19:22:03.011 BST] [ERROR] [init.js:298] (hook.call, command, ./discord/core/accountLink.js) TypeError: Cannot find function resolveUserId in object [email protected]


#52

Scania will need to look at it, I really do my best to stay out of Discord.


#53

I have $.botName being forced to lower case in the core, I guess that’s not happening for some odd reason, or it’s getting reset somewhere else. !botname moderate forces the bot to detect moderator status when the caster remove its moderator status and gives it back without shutting down the bot.

Everything mentioned here got fixed in 7cb8262

Please submit future issues related to Discord in this topic: Discord Module Revamp


#54

Topic is locked or i would also making a new topic is also locked


#55

This below is what i get when i try to link discord to twitch… it does link but the reply doesnt work as its getting Cannot find function resolveUserId errors… i would of posted this in the area you asked but as you see above i cant as its all locked out for me?

[08-19-2017 @ 11:52:48.876 BST] [DISCORD] [#JustAlixe] justalixe: !account link
[08-19-2017 @ 11:52:48.904 BST] [DISCORD] [@justalixe#2397] [DM] **NOTE: This expires in 10 minutes**.
**This will automatically remove your previous account link.**
To complete the process of linking your Discord account to your Twitch account, please login to Twitch, go to **https://twitch.tv/justalixe**, and send the command **!account link p1nAzOoq**
[08-19-2017 @ 11:52:57.007 BST] justalixe: !account link p1nAzOoq
[08-19-2017 @ 11:52:57.070 BST] [ERROR] [init.js:298] (hook.call, command, ./discord/core/accountLink.js) TypeError: Cannot find function resolveUserId in object [email protected]

#56

I am going to start a new thread for Discord Bug Reports. The Nightly Build section is limited to Admins only. Please move any and all Discord Bug Reports to that thread.


#57

Can you lock this thread please


#58