Raspberry Pi 3 and the Youtube Player


#1

Hello, it’s me again with a problem i cannot fix on my own.

I’m running the current Phantombot on my Raspberry PI 3. That works fine.

I’m using the RPi for music playback (using the Headphone Out on the Pi to the Line In on my PC) so i can use this sound source inside my stream and inside of teamspeak for those that want to. I’m controlling playback, volume and such via my StreamDeck and this works fine, too.

For about 2-3 hours. After around this time the Music Playback begins to stop occasionally amidst a song. Bot Responses are delayed also. Not only those that control playback but alerts, text, sound.

I tried to find out what was the problem and the biggest one seems to be the browser that plays back the music on the Pi. so i tried to find an alternative to the installed one (epiphany). only chrome and vivaldi are capable of showing the player but both of them take about 50% of the system ram. not only this, they keep growing while the playlist advances. after 2-3 hours the ram is full and swapping begins. that is what i think the core of the problem. almost only restarting the Pi solves the problem.

I tried several commandline switches like low memory profile, single thread and such. even cgroup was not able to restrict the browsers usage of system resources. no other browser is capable to show the player so i can use it without swallowing up the PIs ram. i tried netsurf, dillo, midori, luakit. they show the loading circle and that’s it.

is there anything i can do? any suggestions?

thanks in advance :slight_smile:


#2

Wouldn’t it be better to run the Youtube Player on your PC? You can put the Sound of your Browser via VirtualAudioCable (or something similar) to Teamspeak.


#3

Indeed, that would work, IF the browser would not always want to use the “default” sound device. Tried a software that claimed to be capable of separating the sound of several programs to the output of my choice. my browser never was impressed of this. Tried this way before i bought the RPi, after having removed all possible software solutions i was aware of at that time.


#4

if your using chrome, there is a add-on!

AudioPick for chrome


#5

Thanks for the suggestion, but that didnt work. i tried it, but nothing changed. The addon only works with html5 playback so i think the cause is that the player does not use html5.

i tried virtual audio cable and something like audio router. that did work kinda, but not dependable enough.

i found the option to hide the video playback, maybe it works better if the browser on the RPi runs in foreground. testing it right now.