Run phantombot on Ubuntu 14.04


#1

Hello,

I got phantombot running on ubuntu 14.04 (open ./launch.sh), but if I close my terminal the but stops running. I want to run it always on the server, without me starting “launch.sh” manually.

I just found a tutorial for Ubuntu 16, but the server I bought, don’t have this version to install.

Can someone help me? Was my first time setting up a server. (it’s just a virtual server I bought online)


#2

this works on other versions to i use it on Linux Mint 19


#3

Yes, I did this tutorial, but:

sudo systemctl daemon-reload
sudo systemctl enable phantombot

doesn’t exist on Ubuntu 14

  • And google doesn’t help much - Hope somebody did this on Ubuntu 14 before.

#4

I just tried:

nohup ./launch.sh &

that currently work. Hope it will later on. No automatic restart, but I can live with that.


#5

With Ubuntu 14.04 you’ll want to use sudo update-rc.d phantombot enable.

After that you can use the following.

sudo service phantombot stop
sudo service phantombot restart (This might not work, to restart you might have to stop and start)
sudo service phantombot start


#6

I got this error: update-rc.d: /etc/init.d/phantombot: file does not exist

What should I write into this file? The same like in the tutorial under 5?

So, this will start the app automatically, when the server restarts for no reason?

I will always check before on stream if the bot is running, but would be nice, if everything works, without have to worry about

Thanks for your fix answer, I will test


#7

You can follow the guide exactly, only difference is that commands aren’t all the same.


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.