Special Chars not displayed in stream title


#1

PhantomBot Version (Version and Build Revision from startup): PhantomBot Version: 2.3.8-NB-20170914 (Revision: 7891d36)
OS and Java Version from Startup: latest
Browser and Version (for Panel Support): Windows Server 2012, Chrome
Stock PhantomBot: Yes
Any Recent Changes to Your System: No

Special chars in stream title are not displayed properly. For example:

:red_circle: [GER/PC] ★ Your title ★

will be like

?? [GER/PC] ? Your title ?


#2

To support multiple operating systems, we support only UTF-8. However, the stars do show up in Chrome on Windows 10, I would need to check a browser from Linux and macOS; if your browser is not displaying those characters, you may want to check on the specific browser configuration.


#3

The good old encoding problems :smiley:
Okay i have to check what’s going on then. Eventually it is the webserver itself because i tried Chrome and Firefox and none display it right. Maybe it the webserver has some ugly iso encoding set :smiley:

Just wonder because bot has its own webserver so i have no clue where i should put utf8 encoding into ^^. I will figure out.

Thanks a lot


#4

We set the encoding on the page to UTF-8. The server doesn’t render that. I’ll do some Googling tomorrow and see if I find anything.

I looked into emote rendering, it essentially requires an additional processing layer for each page. With the way we render and refresh, would need to figure out how that would work.


#5

Didn’t figure out how i could get it working but if it is no bug but a setting of me then all is fine. Thanks for your awesome support. Have a nice weekend :slight_smile:


#6

This topic was automatically closed after 30 days. New replies are no longer allowed.