Stream alert not working


#21

I personally do not use Discord for support unfortunately. I logged out of the PhantomBot Discord some time ago.

I think just seeing the directories and a file is enough for me to take a guess. Replace /bot/directory with the path to your bot directory.

cd /bot/directory 
find . -type d -ls
find . -name phantombot.db -ls
ls -l /bot/directory

View the service file (I do not know where you created it). I believe you are starting the bot via service by the looks of it.

cat /path/to/service.file

#22

Starting the bot via systemctl


#23

I sent the logs to you…


#24

Jun 15, 2018 9:22:32 AM org.apache.http.impl.execchain.RetryExec execute Jun 15 09:22:32 vmi168357.contaboserver.net launch-service.sh[4308]: INFO: I/O exception (java.net.SocketException) caught when processing request to {s}->https://discordapp.Jun 15 09:22:32 vmi168357.contaboserver.net launch-service.sh[4308]: Jun 15, 2018 9:22:32 AM org.apache.http.impl.execchain.RetryExec execute Jun 15 09:22:32 vmi168357.contaboserver.net launch-service.sh[4308]: INFO: Retrying request to {s}->https://discordapp.com:443

I tried changing the discord key to a new one as well as regiving it perms again and got this error


#25

Have you tried verifying that you can reach https://discordapp.com:443 from your server? That error indicates that ssl traffic (over port 443) is being denied by your server. Upgrades, or patches to your server via yourself or your hosting provider may have reverted previous configuration settings.


#26

How do I check?


#27

How do I check and if not how do I open it


#28

That depends on your host, and the operating system. Your hosting provider should provide a guide, if not Google will be your friend here (a simple “how to open ports HostingProviderName OperatingSystem” should get you what you need).

For a test, you can use netcat or something similar.


#29

It does connect.

I did a wget on the website and got

FINISHED --2018-07-07 20:01:28--
Total wall clock time: 13s
Downloaded: 152 files, 6.0M in 2.7s (2.20 MB/s)

#30

The two errors it keeps giving me are nullpointerexception and broken pipe. I’m going to zip up the error files now. Who would be best to send it to?


#31

As mentioned in Discord, my best suggestions are:

  1. Wipe the Linux server clean.
  2. See about using a different service provider.
  3. Also, does the bot run properly from your own PC?

These errors appear to be related to the configuration of the OS and we cannot provide support at the OS level. It seems that there have been issues with the configuration of Java (not PhantomBot), permissions and now a broken pipe could indicate a network or process level issue within your OS. PhantomBot uses the library routines provided by Java and we cannot dig into that code to troubleshoot. A developer has taken your bot code, minus the botlogin.txt, and been able to execute PhantomBot without issue which does also seem to point to an OS level issue.

As a side note, a broken pipe in Java indicates:

It is caused by something causing the connection to close. (It is not your application that closed the connection: that would have resulted in a different exception.) It is not possible to recover the connection. You need to open a new one.

So, something on your server/providers network is probably closing the connection, like it says, it isn’t the application that closed it.


#32

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.