Ytplayer/songrequest not opening


#1

When i go the yt player/song requests, it is stuck on the loading screen and says this

[ERROR] [handleFile()@HTTPServerCommon.java:475] HTTP Server: handleFile(): .\web\beta-panel\pages\undefined\ytplayer (The system cannot find the path specified)

turning debugon

it RAPIDLY spams cmd with

[08-05-2018 @ 17:29:05.670 GMT] [DEBUG] [GetData()@YouTubeAPIv3.java:264] YouTubeAPIv3.GetData Timers 0 0 37 37 Sun Aug 05 10:29:05 PDT 2018 Sun Aug 05 10:29:05 PDT 2018
[08-05-2018 @ 17:29:05.672 GMT] [DEBUG] [GetData()@YouTubeAPIv3.java:267] YouTubeAPIv3.GetData Exception
[08-05-2018 @ 17:29:05.672 GMT] [DEBUG] [GetData()@YouTubeAPIv3.java:268] YouTubeAPIv3.GetData HTTP/Available 403(403)/0(-1)
[08-05-2018 @ 17:29:05.673 GMT] [DEBUG] [GetData()@YouTubeAPIv3.java:269] YouTubeAPIv3.GetData RawContent[0,100] {
“error”: {
“errors”: [
{
“domain”: “usageLimits”,
“reason”: “accessNotConfigured”,

[08-05-2018 @ 17:29:05.674 GMT] [DEBUG] [GetVideoLength()@YouTubeAPIv3.java:440] YouTubeAPIv3.GetVideoLength Fail2

[08-05-2018 @ 17:29:05.675 GMT] [DEBUG] [GetVideoLength()@YouTubeAPIv3.java:380] YouTubeAPIv3.GetVideoLength Start id=gotxnim9h8w


Youtube player from http://localhost:25000/ytplayer is absolutely not reacting!
Bot not adding Song Requests but does not return any error message
Youtube player songrequest
Youtube player not working except one link
#2

It seems like YouTube changed something with their API, only @IllusionaryOne has access to account that has the API, so once he comes back he’ll have to look into it. For now, you can get your own API key and this will fix the issue.

Guide: Acquire YouTube API Key


Youtube player error no data found
YTPlayer won't open for me
Phantombot 2.4.1 youtube player will not allow me to add songs
YouTube player socket issues - FireFox
#3

What’s the proper flag for setting my own API key? Is it “youtubekey=” in botlogin.txt
I’m on the nightly build


#4

It is yes.


#5

Unfortunately, I do not have access to the account that provides the YouTube API key. Either we were using a very old one from a previous developer and that developer removed the project or the API key was blocked due to abuse; the error message can be related to the following:

accessNotConfigured Your project is not configured to access this API. Please use the Google Developers Console to activate the API for your project.
accessNotConfigured The project has been blocked due to abuse. See http://support.google.com/code/go/developer_compliance.
accessNotConfigured The project has been marked for deletion.

#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.