Java 8 Required as of PhantomBot 2.3.3


  • Bot Developer

    If PhantomBot 2.3.3 or later is started up and appears to hang, please review the stacktrace.txt file. You may see a message such as:

    11-04-2016 @ 19:09:25Z (Thread[main,5,main]) java.lang.UnsupportedClassVersionError: net/dv8tion/jda/exceptions/RateLimitedException : Unsupported major.minor version 52.0
    

    The library that is used to provide Discord support requires Java 8, and as such, you will need to ensure that you have Java 8 installed on your system.

    [EDIT] Upcoming launch scripts will detect what version of Java is being used and not start PhantomBot.

    Please install Java 8 onto your system to resolve the issue.

    RedHat Based Linux (includes CentOS)
    yum install java-1.8.0-openjdk

    Fedora Linux
    dnf install java-1.8.0-openjdk

    Debian Based Linux (includes Ubuntu)
    apt-get install openjdk-8-jdk

    macOS
    Please visit http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
    Note that the JDK is required rather than the JRE, select the Mac OS X version for download

    Windows
    Please visit https://www.java.com/download

    We apologize for any inconvenience that this may cause as we continue to add new features and options for the community.


Log in to reply
 

Looks like your connection to PhantomBot Community Forums was lost, please wait while we try to reconnect.